Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega CTI Link not Available

SA-11091

Summary



Administrator has created a CTI Link instance. The Test Connection is successful, however, the instance is not visible in the PegaCALL Utilities landing page and in the PegaCall toolbar drop-down selection list.

Error Messages





Steps to Reproduce



1. Log into CPM system.
2. Create a CTI Link instance.
3. Navigate to PegaCALL Utilities landing page and the newly created CTI Link instance is not visible. 


Root Cause



This is an upgraded CPM 7.1.3 system from CPM 6.2 SP1. After the upgrade, the administrator has also installed the PegaCALL application from 114514_PCALL71 media. This PegaCALL media has been released before CPM 7.1.3 and the CTI codeset version is 07-01-01 and not 07-13-20 as in the CPM 7.1.3 media. This codeset conflict is causing the PYGETALLLINKS activity not able to execute and the error is found in the clipboard.

Resolution



1.Backup the database.
2.Use the Application -> Distribution -> Import Utility to import prchannelservices.jar taken from CPM 7.1.3 media (114696_CPM713\Install\RuleSetsAndData\CPM_713_Install\pegafw-channelservices\prchannelservices.jar).
3.Restart all the server nodes.

Published July 13, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us