Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega IAC does not work in Websphere Portal

SA-24188

Summary



When accessing a Pega 7 application delivered by Internet Application Composer (IAC) to a websphere portal, an error is thrown on screen.


Error Messages



PRGateway Exception: Invalid URL


Steps to Reproduce



User has a Pega 7 screen in embedded in WebSphere portal using IAC, it does not work. There is no error message on screen when accessing the portal.


Root Cause



The issue is due to a defect in the product and for a configuration issue in the operating environment.

The gateway and the PEGA server was installed on the same JVM and user was also having Webseal in front of the gateway. 
The request traverse from browser to Gateway through WebSeal and from Gateway to PRPC. Being the Gateway and the PEGA are on the same JVM, there is a circular reference. The gateway is not required in this setup as the Webseal is serving as the proxy server.

Resolution



Remove or bypass the Gateway and directly access the Pega Server by setting the Gadget parameter "Pega.web.config.gatewayURL" to the relative URL as follows:
Pega.web.config.gatewayURL = "/prweb/IAC"

The PRGateway application is not required if other applications are already providing Same Domain Origin Policy. The PRGateway application was written with the intent that it could be deployed alongside, within the same domain, of the primary application. The back end communications to PRPC from the PRGateway could then be sent through firewalls and so on allowing for Same Domain Origin policy to be satisfied. 
 
There is no requirement to deploy the PRGateway within the same JVM as PRPC except for development or proof of concepts.  

The PRGateway is simply a proxy server. If there are already proxying content from requests made outside of a DMZ into inside a DMZ, for example WebSEAL, then user can directly go to PRPC URL. 


Related PDN article:

https://pdn.pega.com/support-articles/error-screen-while-connect-portal-iac-instance
Suggest Edit

Published June 16, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us