Support Article
Pega Marketing application performance issue
Summary
User is experiencing poor performance when executing outbound email campaigns and time-outs when accessing the portal.
Also experiencing time-outs while trying to access links in emails (that redirect via HTTP Response Service).
Error Messages
“server reached MaxRequestWorkers”
Steps to Reproduce
Run an Outbound email Campaign with 400,000 cases, sending HTML formatted email via SMTP relay.
Root Cause
The cause of the initial problem was Requestor Pool exhaustion.
It was not because the pools were incorrectly sized, but more because the incoming traffic was not being serviced quickly enough, and the requests were backlogged.
Resolution
Perform necessary load tests to correctly size the application server nodes.
Published August 23, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.