Support Article
Pega server cannot start after server restart
SA-33538
Summary
At first there is an error when user tried to create a new case type (there is an error with @Baseclass) So user restarted the server.
After server start up, JBoss successfully up and deployed prhelp and prsysmgmt (it can accessed); but while deploying prweb it crash with an info like "[LOCAL] [564462a54e8efab83241814626c1214c] [3.4.1] Interfaces is disabled, trying to pick one address from TCP-IP config addresses: []" and all deployed apps got undeployed.
Error Messages
2017-02-03 14:49:49,383 [ pegalinux] [ STANDARD] [ ] [ ] ( priv.context.JNDIEnvironment) ERROR - Exception during getEJBInstance "com.pega.pegarules.internal.etier.interfaces.EngineLocalHome"
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
Steps to Reproduce
This occurs when Pega starts up a single node system.
Root Cause
Deployment of prpc_j2ee14_jboss61JBM.ear was taking longer time than the timeout configured on JBoss.
Resolution
Below change resolved the behavior.
Change configuration:
<property name="-Djboss.as.management.blocking.timeout" value="600"/> to
<property name="jboss.as.management.blocking.timeout" value="10800"/>
Published February 20, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.