Support Article
Pega startup fails StringIndexOutOfBoundsException due to logs
SA-30197
Summary
Pega application will not process after user restarts the appserver. Relevant PDN article - https://pdn.pega.com/support-articles/prpc-718-fails-start-due-log-file-appender-issues. "PegaRULES-FirstLogCreationTime.log and PegaRULES-ALERT-FirstLogCreationTime.log file are of zero byte size in the file system. PRPC finds this file in the file system and throws the above exception."
Error Messages
log4j:ERROR Cannot write to /usr/WebSphere/AppServer/profiles/AppSrv/temp/WASNode_cs1bcmapd01/appserver01/
PRPC_j2ee14_ws01/prweb.war/PegaRULES-FirstLogCreationTime.log
[10/30/16 19:47:14:288 EDT] 0000007c PRBootstrap E com.pega.pegarules.internal.bootstrap.PRBootstrap Problem during method invocation (contextInitialized) java.lang.StringIndexOutOfBoundsException
at java.lang.String.<init>(String.java:183)
at com.pega.pegarules.priv.util.LogDeleteUtil.readFromFile(LogDeleteUtil.java:296)
Steps to Reproduce
Restart appserver. (Pega does not come up)
Root Cause
The root cause for this scenario is that a file system storage space issue results in the presence of zero byte file in log directory (PegaRULES-FirstLogCreationTime.log).
Resolution
Refer to PDN article to get instance up and running - https://pdn.pega.com/support-articles/prpc-718-fails-start-due-log-file-appender-issues.
Install HFix-30333 to prevent this issue in the future.
Published November 10, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.