Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

PEGA0005 alert for SPPR_SYS_RESERVEQ and SPPR_PURGE_TABLE

SA-15707

Summary



In many applications, PEGA0005 alerts are caused by two stored procedures, SPPR_SYS_RESERVEQ and SPPR_PURGE_TABLE.
 

Error Messages



PEGA0005 Database query operation has exceeded an elapsed time threshold setting.


Steps to Reproduce



In Pega applications that use the stored procedures Pega_DATA.SPPR_SYS_RESERVEQ and PEGADATA.SPPR_PURGE_TABLE, notice the PEGA0005 alert.


Root Cause



A defect or configuration issue in the operating environment

Pega-provided database tables take an excessively long time to respond to the server.

Resolution



Examine the stored procedures Pega_DATA.SPPR_SYS_RESERVEQ and PEGADATA.SPPR_PURGE_TABLE to identify opportunities to optimize performance.

See the following references:

SA-1076, Lock exhaustion in DB caused by SPPR_PURGE_TABLE Stored Proc

Pega 7.1 Help topic
How to analyze system-wide usage with the Log-Usage class

 

Published January 18, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us