Support Article
PegaAESRemote cannot open required activities after HF update
SA-95201
Summary
After deploying HFix-51553 and its requirements, PegaAESRemote 7-10 changes to PegaAESRemote 7-22. However, PegaAESRemote cannot access rules such as DeadlockInfo and activities in PegaAESRemote 7-22-04.
On adding the PegaRULES:SecurityAdministrator privilege to PegaAESRemote, the user can open and access the rule. Else, PegaAESRemote-Interface-DeadlockInfo error occurs.
Error Messages
[STANDARD] [PegaAESRemote:07.22] (internal.mgmt.Executable) ERROR - Execution denied for class: PegaAESRemote-Interface-DeadlockInfo (activity: PushDeadlockInfo)
Steps to Reproduce
- Migrate Pega Platform 7.1.2 to Pega Platform 7.2.2.
- Apply HFix-51553 to update AES.
- Execute the activities which the PegaAESRemote agent uses. Verify the logs.
Root Cause
The hotfix Update rules were not retrieved.
Resolution
Perform the following local-change:
- Delete all PegaAESRemote Agent Schedule instances. These are automatically recreated after 10 minutes or after a restart. Their schedules often refer to the older versions even after a hotfix install which updates the agent.
- Clear the Conclusion Cache from memory and the database using the System Management Application (SMA).
a. In the SMA, navigate to Advanced > Conclusion Cache.
b. Click 'Clear Conclusion Cache in Memory'.
c. Click 'Clear Conclusion Cache in Database'.
- Restart the servers.
Published January 28, 2020 - Updated October 8, 2020
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