Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Poor performance when running Adaptive model with high user load

SA-12503

Summary



While performing application performance testing, performance slows when running an Adaptive model. On removing the Adaptive model shape from the Strategy and running the performance tests, the results were much better. User needs to complete each step of the use case in the performance testing within 3 seconds or less at the 90th percentile level. Adaptive model has about 150 Predictors. 

Error Messages



Not Applicable


Steps to Reproduce



1. Run the Performance test for 1000 users.
2. After ramping up to 1000 users, performance degrades significantly.
3. Performance appears good up to 700 - 1000 users, then degrades. Treatment and Accept steps response times start to rise to tens of seconds.


Root Cause



Audit Notes on the adaptive model was enabled which was contributing to slowness.

Resolution



Disable “Audit Notes” on the Adaptive model in the application to resolve the issue.

Published July 30, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us