Support Article
Pop-up menus persist and other UI issues with Chrome
Summary
Users experience various user interface issues when using Chrome on touchscreen laptops for Pega applications.
For example, the following three problems were reported for Chrome with laptop model T460s running Windows 7:
- Menu control overlay does not display, but it opens the main landing page.
- Calendar Date Controls do not work on screens. Users must type the date.
- Right-click on Designer Studio objects does not display the Pega context menu. Instead it displays the browser's context menu
Reinstalling Chrome and removing all add-ons did not fix these issues.
Error Messages
Not Applicable
Steps to Reproduce
- Open a context menu for an object in Designer Studio and navigate away from the menu. The menu does not close, but stays open.
- Click a choice on a context menu and notice that the cascading menu does not display.
- Navigate to Pega Academy, click Course Library. The library does not open.
Root Cause
Pega product limitation needs a product enhancement request.
A laptop running Chrome with "ontouchstart" in document.documentElement returns "true" for desktop.
This problem using the Chrome browser for Pega applications occurs with touchscreen laptops when both touchscreen and mouse functionality is used.
Resolution
Perform the following local-change in Chrome if you are using a touchscreen laptop:
- Check to see whether you have enabled touch events by testing “chrome://flags/” URL.
- Disable Touch events in "chrome://flags/#touch-events".
- After disabling the touch event flags in Chrome, work through incognito mode.
Two Pega product enhancement requests were submitted for consideration by Pega Product Management:
FDBK-13640
FDBK-13582
Published April 7, 2017 - Updated October 8, 2020
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