Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Portals are not rendering the section properly

SA-38565

Summary



User made changes for few rules in ruleset version in their application environment.

However, due to these changes they observed that all portals got blanked out for a particular section which are related to the application change.

Error Messages



Not Applicable


Steps to Reproduce



1. Copy the rule from higher ruleset version to lower version.
2. Observe whether the rule is executed during run time.


Root Cause



An issue in the custom application code or rules.

User has a list view control in the section configured in higher ruleset.

Later, user has copied the section and pasted it the lower ruleset version, and somehow the generated java for the rule was not generated properly.

That is, the list view was not copied properly.

Resolution



Perform the following local-change:

Re-configure the section in the lower ruleset, by adding the list view explicitly in the section and save the rule.

By this, the stream rule was properly re-generated and the portal was able to render the section/list view during run time.


Suggest Edit

Published July 5, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us