Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Prerequisite issue in KYC Ruleset

SA-615

Summary



Users are getting some ruleset prerequisite issue with KYC framework rulesets SampleFSDueDiligence. In the application PegaKYC 01-09-75 version is present whereas in SampleFSDueDiligence ruleset PegaKYC 01-09-46 version is given. Because of this issue users are not able to update their application with new Ruleset version.

Error Messages



Invalid value specified for pyRequiresRuleSetVersionElement. Value doesn’t adhere to the validate: pzValidateRuleSetAndVersion.

Steps to Reproduce



Open RuleSet SampleFSDueDiligence’s Required RuleSets And Version.


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.

Resolution



Update SampleFSDueDiligence ruleset pre-requisite.
 
Suggest Edit

Published March 21, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us