Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Preview of Correspondence is changing background screen

SA-31003

Summary



On previewing a correspondance, the background harness is changing.


Error Messages



Not applicable


Steps to Reproduce



1. Log into Pega7.
2. Launch Manager Portal and Create a payment case of any type.
3. Create a correspondence and select a correspondence type Swift.
4. Select message type, for example MT191.
5. Enter the Required fields.
6. Click on Preview.
7. Observe that the background screen is changed and could not see the complete data.


Root Cause



By comparing tracers provided by developer and the one with Out-of-the-box (OOTB), one could see that WHEN condition in 15th step of ‘PostCreateStructMessage’ activity is getting true in developer case. But the WHEN condition should be false and exit the activity.

The WHEN condition is checking for ‘Param.DisableActionFrame=="true"’. In OOTB login the parameter is set to true.

But at developer end the parameter is not set.

So checked the configuration of the Preview button and compared it with OOTB one.

​In OOTB, the Preview button is picked from ‘CreatedStructMessage’ section and the actions are configured with ‘RefreshSection’ and pre activity ‘PreviewStructMessage’.

One could observe at user end the Preview button is customized. And the actions on the button are different.

Resolution

Use the OOTB 'CreatedStructMessage' section or replace the actions on the ‘Preview’ button with ‘RefreshSection’ with Pre activity ‘PreviewStructMessage’.

 

Published December 9, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us