Support Article

PR_LOG_REPORTSTATS table enters the Unavailable state

SA-73325

Summary



The PR_LOG_REPORTSTATS table enters the Unavailable state. As a result, the log size increases.


Error Messages



ERROR - Encountered an error when saving instance "LOG-REPORTSTATISTICS HC6C88878FF8D55F59784B99ADAF29B88!928329C92B81B4C446329F1AAB271BD8!RULE-OBJ-REPORT-DEFINITION INDEX-OPERATOR-WORKGROUPS PXGETOPERATORWORKGROUPS GMT!EMBEDDED!GMT" of class Log-ReportStatistics

com.ibm.db2.jcc.am.SqlException: For table "PR_LOG_REPORTSTATS" an object "21" in table space "4" cannot be accessed.. SQLCODE=-1477, SQLSTATE=55019, DRIVER=3.67.27


Steps to Reproduce



Not Applicable


Root Cause



A defect or configuration issue in the operating environment.


Resolution



Perform the following local-change:

Collect the statistics and write it to the PR_LOG_REPORTSTATS table. This enables the user to write reports to determine the following:
  1. How often the reports are run and by whom?
  2. How long the reports take to run and how many rows of data are returned?

Use the following Dynamic System Setting (DSS) to change how this statistics is stored in the database. Change the DSS as required.

reporting/reportstatistics/minimumDaysToPurgeFromDatabase

Default value: 30 days

Removing 'Not Logged initially' has performance implications. The System Cleaner purges eligible records from the table and turns the table to Not Logged Initially. The change is active until the next run. There is no control to change this behavior for a specific table.

Published February 12, 2019 — Updated August 19, 2019

Have a question? Get answers now.

Visit the Pega Support Community to ask questions, engage in discussions, and help others.