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Support Article

The problem flow assignment is not removed when a ticket is set

SA-14469

Summary



A local action is used to set a ticket that will re-initiate the flow from the beginning. When the local action is performed from a regular flow assignment, the flow proceeds to the point of the ticket and the current assignment is removed. When the local action is initiated from a problem flow assignment, the flow proceeds to the point of the ticket but the problem flow remains and the assignment is not removed.


Error Messages



Not Applicable


Steps to Reproduce

  1. Add a case wide local action that sets a ticket to re-initiate the flow from the beginning.
  2. Run the flow and force it to create a problem flow.
  3. Run the local action from the problem flow assignment.


Root Cause



The problem flow assignment is not removed because the pyIssuedFromFlow property is not set. The RemoveAssignmentByTicket and CleanUpSplit functions are used when a ticket is raised. In the CleanUpSplit function the code checks the pyIssuedFromFlow property to determine if the flow should be removed. This is the expected behavior for a problem flow. 

Resolution



The default behavior can be modified by setting the pyIssuedFromFlow property in the Work-.ProblemFlow activity.

Published October 1, 2015 - Updated October 8, 2020

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