Support Article
Problem with Select All feature on complex checkbox question
SA-3445
Summary
A Complex Checkboxes question has been added to a survey. When clicking the Select or UnSelect All option, all of the checkboxes are selected for a moment but then just only one option remains selected. It is not always the same item that remains selected.
Error Messages
Not applicable.
Steps to Reproduce
- Run a survey with a complex checkbox question.
- Click on the Select or UnSelect All check box.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. The issue occurs after installing HFix-7555 and has been resolved in a later release of PegaSurvey.
Resolution
The issue is resolved by installing PegaSurvey 6.3 SP3 and the relevant hot fixes.
Installation Instructions:
- Install Pega Survey 6.3 SP3.
- Install HFix-9739, HFix-9740, and HFix-10096.
- Stop the servers, remove the PegaRULES_Extract_Marker.txt file from the temporary directory, and restart the servers.
- Revalidate and save the questions, question pages, and surveys.
Published January 31, 2016 - Updated October 8, 2020
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