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Support Article

Problem to update a Case Type in a Branch

SA-17711

Summary



Attempting to use the case editor to update a case type in a branch ruleset, when the only available rulesets are branch rulesets, returns a message stating that the ruleset is locked when it is not.


Error Messages



The rulset <ruleset name>_Branch_<Branch Name> :01-01-01 is locked.  Please unlock it to save changes and proceed.


Steps to Reproduce

  1. Create a Branch from base RuleSet which is locked
  2. Save the Case Type in the Branch
  3. Try to update the Case Type from Case Designer, for example - adding a Step


Root Cause



A defect in Pegasystems’ code or rules.

Resolution



This behavior is fixed in Pega 7.1.9

Perform the below local-changes in Pega 7.1.8:

Unlock the base rulesets to use case editor.

OR:


1. Locate the activity rule pzLoadCaseTypeStages and open it in the Designer Studio. You may need to search for this using the syntax “old: pzLoadCaseTypeStages” as it is an internal rule and will not show up in a regular search.
2. Private Check out the rule
3. Update Step 17 as below, by checking the bCheckValidityOfCurrentRS parameter for the call to pxChooseBestRuleset.
 



 

4. Use the Case Editor to make the required changes.

Published January 31, 2016 - Updated October 8, 2020

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