Support Article
ProcessServiceQueue fail to find instance from queue
SA-38576
Summary
User reported that they are seeing multiple "InstanceNotFound", error and PRQueueException are logged in the PegaRules.log file.
Error Messages
com.pega.pegarules.pub.context.PRQueueException: InstanceNotFound Queue SYSTEM-QUEUE-EXECUTIONREQUEST-CONNECT-DEFAULT
Steps to Reproduce
Not Applicable
Root Cause
A defect in Pegasystems code or rules
The processing mode for few Services is set as Asynchronous, this can leave queue items with status as "Immediate".
Such queue items should be processed separately.
Resolution
Perform the following local-change steps:
1. Create a custom Agent in your application ruleset, similar to “ProcessServiceQueue” in “Pega-IntSvcs” ruleset.
2. Use “ProcessImmediateQueueItems” Activity instead of “ProcessQueue”.
Published July 11, 2017 - Updated October 8, 2020
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