Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Program shows Running status even with execution in logs

SA-28485

Summary



Users have a scenario where they get an exception in the Outbound Program execution however this exception does not get propagated to the User Interface. The Program status is shown as Running in the Pega Marketing portal. This basically means that the business users have no idea whether the Program is running or not.

The issue with the exception handling it is not propagated to the Program Execution activity and the status of the Program is not appropriately updated.

Error Messages



Caused by SQL Problems.
Problem #1, SQLState 42000, Error code 1792: java.sql.SQLSyntaxErrorException: ORA-01792: maximum number of columns in a table or view is 1000

Steps to Reproduce



Run a Marketing Program, with SR Properties generated were more than 1000 for the Batch Output table.

Root Cause



Reported exception was occurred due to ORA-01792 which basically is a 1000 column limit in Oracle while generating the Batch Output table. This exception does not propagate to the User Interface and this has been identified as issue with the product.

Resolution



Apply HFix-29420 for address the reported behaviour.
Note that HFix-28198 is a pre-requisite and must be applied before applying HFix-29420.

Published August 23, 2017 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us