Support Article
Property ‘CAParentID' is not a DatabaseColumn
SA-7854
Summary
Post CMPHC 713 installation on Microsoft SQL Server, the validation procedure described in the installation manual produces error.
Error Messages
Property ‘CAParentID' is not a DatabaseColumn
Steps to Reproduce
Install or Upgrade CPMHC712 or PCSHC713 using out-of-the-box scripts on MS-SQL database where collation is set to case sensitive.
Post installation, validate the setup as per guide.
1. Log in as CPMHCSysAdmin
2. Launch the Interaction Portal
3. Click on the +New at the top of the page
4. Select Phone Call – Member
Root Cause
Below MS-SQL scripts create table 'cpmhc_work' with column 'CAPARENTID' (all upper case) instead of 'CAParentID'(camel case) and thus MS-SQL database for administrator, where table and column names are case sensitive, fails to resolve the reference of property CAParentID to column CAPARENTID.
114794_PCSHC713.zip\Install\DDL\CPMHC_mssql.sql
114646_CPMHC712.zip\Install\DDL\CPMHC_mssql.sql
114646_CPMHC712.zip\Upgrade\DDL\CPMHC_Upgrade_mssql.sql
Resolution
Either alter the column name to CAParentID or switch the collation as case insensitive in MS-SQL database.
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.