Support Article
PRPC doesn't login/load after sign-in
SA-5130
Summary
PRPC doesn't login/load after providing login details. Websphere is being used a app server and got the below error message in the logs.
Error Messages
Listener failed to connect to data source PegaRULES. (but data source connectivity is successful)
Steps to Reproduce
1. Start the app server.
2. Make sure pega war ear files are deployed.
3. Login to prpc portal.
Root Cause
The root cause of this problem is related database connection propertieis on IBM websphere.
Resolution
This issue is resolved by making the following change to the PRPC appserver environment:
The Minimum Connections and Maximum Connections has been altered from 1 and 10 to 10 and 50 respectively to facilitate connection pooling and to address the user issue.
Published January 31, 2016 - Updated October 8, 2020
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