Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

PRPC62SP2ML1[LV]Decimals display problem on Listview

SA-1985

Summary



When including a decimal field in a ListView, not all the decimals are being displayed as expected. For example, a decimal value have been persisted as 0.000022824 in the database. However, when running the ListView, the values is being displayed as 0.

Error Messages



N/A


Steps to Reproduce



Create a decimal property and expose it in the database. 
Create a workitem referencing this field and enter 0.000022824.
Create a ListView reportiung the decimal property and it display as 0.

Root Cause



This is a formatting issue. The decimal field in the ListView can be applied with a format to include all the decimals.

Resolution



To overcome the issue, save a copy of the pxNumber Control rule into the application ruleset. Modify the newly created Control rule by changing the "Decimal Places" attribute to All. In the ListView, associate the control to the decimal field.




 
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us