Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

PRPCUtils latency issue with Pega 7.1.7

SA-53299

Summary



Executing prpcutils.bat import to deploy rules takes 30-40 minutes with Pega 7.1.7.


Error Messages



Not applicable


Steps to Reproduce



Execute prpcUtils.bat command to deploy product archives.


Root Cause



A defect in Pegasystems’ code or rules:

 By default prpcUtils generates new temporary directory for every execution. Here it extracts Pega code and generates all the caching content which can take a while.

Thus time of execution for successive runs stays long.

Resolution



Follow the steps documented in below PDN article:

https://pdn.pega.com/support-articles/prpcutils-running-slowly

This allows prpcUtils to leverage contents generated in the first time execution for successive runs.
 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us