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Support Article

prPushServlet pooling on accessing Pega app through proxy

SA-81778

Summary



Continous prPushServlet pooling occurs when accessing the Pega application through a proxy. 
The user has Apache 2.2 server which is Windows based and which does not support WebSockets.



Error Messages



Not Applicable


Steps to Reproduce



Unknown


Root Cause



Below are the reasons for the large number of requests:
  1. Due to the proxy, HTTP 302 redirect response is received for every request. The next request receives HTTP 200 OK status. Hence, the number of requests is doubled.
  2. According to Long Polling design, a long polling request is sent to the server every two minutes. During this gap, polling requests (heartbeat) are sent to check if the user is still logged in or has closed the browser/tab so that the server can clear the assigned resources. By default, this request occurs thrice per minute.

Resolution



Perform the folloiwng local-change:

Add the below line in prconfig.xml to configure the interval setting (for example, the interval value is in seconds; that is, the value is set 120 seconds for an interval of two minutes).


<env name="server-push/client-heartbeat/interval" value="120"/>

Published December 2, 2021

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