Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

PR_SYS_WORKINDEXER_QUEUE table size getting extremely large

SA-7630

Summary



We got some database utilization static and found that the largest table in database is PR_SYS_WORKINDEXER_QUEUE (8855552 KB) which is larger than attachment table (PC_DATA_WORKATTACH, 8613888 KB). Is this a normal behaviour?

Error Messages



Not Applicable

Steps to Reproduce



Not Applicable

Root Cause



The settings for the default search node matched none of the available PRPC nodes which was causing items to remain in queue since there was no Agent capable of processing.

Resolution



This issue was resolved after settings on Indexing (Search) Landing Page were configured properly. We should set one of the current PRPC nodes as the declared Indexing node. After the HostName and HostID matched one of the nodes and after the SystemWorkIndexer agent was enabled on that node, work items were processed from the queue.

 
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us