Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Publish to Dashboard is not working

SA-44332

Summary



After selecting a widget to display on Dashboard, a blank screen is displayed to the users.

The widget selected is not getting added to the slot and hence when published, not visible to the users.


Error Messages



Blank screen is shown. Below is the error in logs

2017-09-04 15:09:30,573 [jp-bio-8009-exec-714] [OpenPortal] [ ] [ LCM:01.01.01] ( AutoPopulateFeature) ERROR xx.pegacloud.com|14.434.178.37 abc - Expected a page type property for reference: .pxUserDashboard.pySlots(1).pyWidgets(1).pyWidget
2017-09-04 15:09:30,574 [jp-bio-8009-exec-714] [OpenPortal] [ ] [ LCM:01.01.01] ( AutoPopulateFeature) ERROR xx.pegacloud.com|14.434.145.37 abc - Expected a page type property for reference: .pxUserDashboard.pySlots(1).pyWidgets(1).pyWidget.pxUserDashboardWidgetOptions


Steps to Reproduce

  1. Launch Portal.
  2. Click on Gear Icon on top right to Edit Dashboard.
  3. Add a widget and press publish.


Root Cause



pxObjClass of an embedded page (pyWidget) of a page list property is not being set properly.

Resolution



Apply HFix-37564.
Suggest Edit

Published November 7, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us