Support Article
Pulse Mention does not work and causes Requestor timeout
SA-79857
Summary
Unable to send a notification using the @ Mention functionality in Pulse. The requestor session hangs due to requestor lock exceptions and thread dumps in the logs.
Error Messages
Exception Occurred in Get Case Details API with error:
[sse-nio-8402-exec-42] [ ] [ ] [ ] (ngineinterface.service.HttpAPI) ERROR - : com.pega.pegarules.pub.context.RequestorLockException
com.pega.pegarules.pub.context.RequestorLockException: Unable to synchronize on requestor HULBNYV6J598FFM4APYQ766OZELUQUHK6 within 120 seconds: (thisThread = https-jsse-nio-8402-exec-42) (originally locked by = https-jsse-nio-8402-exec-43) (finally locked by = https-jsse-nio-8402-exec-43)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.throwRequestorLockException(PRSessionProviderImpl.java:1550) ~[prprivate.jar:?]
Steps to Reproduce
- Open a Service Case.
- Click the Feed tab.
- Click Composite360. When inputing Mention (@operator test) different user, the notification is not sent and the requestor hangs.
Root Cause
A defect or configuration issue in the operating environment.
The Avaya CTI link create session failed before thread dump generation.
Resolution
Here’s the explanation for the reported behavior:
User did not use the Avaya out-of-the-box shipped CTI link in the application and this link failed to start since it is set to auto start by default.
When this failure occurred, thread dumps are generated. As a result, the requestor hangs for a while and restored.
Perform the following local-change:
- Disable the auto start of the Avaya CTI link from Pega Designer Studio > Channel Services > Pega Call > Administration & Configuration > Avaya (Disable AutoStart checkbox).
- Delete the auto start with a server restart if it is not used anymore.
Published August 15, 2019 - Updated December 2, 2021
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