Support Article
Pulse not showing new Post
SA-99177
Summary
When an Agent posts a note and the other Agent refreshes the Pulse section, the current post does not display at the top. Instead, an old post displays.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Case Manager portal.
- Click Pulse.
- Enter a Comment in the Pulse from the ID of User 1.
- Parallelly, if the client is logged in as User 2 and is in the Pulse. The update displays on top as '1 New Update'.
- Click the Update button. The old post displays.
Root Cause
Report definition and data transform parameters were configured incorrectly.
Resolution
Perform the following local-change:
- Ensure that the Context Key and FeedLabel are the same, where the Context Key is used in the Parameters tab in 'pyPulseWrapper section (class: Data-Portal)' and the FeedLabel is used in the pyClearPulseFeed data transform (class: Data-Portal)
- In the pyGetContextPosts (PegaSocial-Message) report definition for pxCreateDateTime Column, set the Sort type to 'Highest to Lowest'.
Published February 11, 2020 - Updated December 2, 2021
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