Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Purge or archive wizard is not running

SA-19893

Summary



When scheduling a purge or archive through the wizard to purge records on a specific criteria, the Agent does not complete. It continuously restarts and populates the logs with the following error.
 


Error Messages



Exiting the Purge or Archive process due to a detected loop. please increase the commit rate to avoid an infinite loop

Steps to Reproduce

  1. Use the OOB purge or archive wizard, select work types, specify the criteria and periodicity of Agent run.
  2. Review the logs after the targeted run time has passed.


Root Cause



A defect or configuration issue in the operating environment. The environment had an issue in which covered items were resolved after the cover. This discontinuity is determined to be an error as the parent is eligible and the child is not yet eligible for purging and gives the indication that a cycle of errors is occurring.

Resolution



Perform the following local-change: 

Correct the incorrect resolved time stamps on the items of interest and then attempt to run the purge tool.

Published February 20, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us