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Support Article

PushExceptions in Monitoring tool

SA-77139

Summary



The DATA-ADMIN-SYSTEM-SETTINGS PEGA-ENGINE!PRCONFIG/SERVER-PUSH/ENABLED/DEFAULT (set to false) Dynamic System Setting (DSS) is disabled and the Servlet in the prweb is commented.

For more information, refer to: https://community.pega.com/support/support-articles/http-server-logs-rapidly-filling




When using a third-party monitoring tool (DynaTrace), PushException occurs in the purepaths (126k entries within two hours).


Error Messages



com.pega.pegarules.session.external.serverpush.PushException


Steps to Reproduce

  1. Disable Push using a DSS.
  2. Comment the PRPushServlet.
  3. Log in to the Pega application from Designer Studio.


Root Cause



This behavior is as per Pega product design.


Resolution



Here's the explanation for the reported behavior:

The PushException occurred in the Monitoring tool because it is an internal exception. Internal exceptions are used to handle special conditions. Since the sections attempt to publish or are subscribed to a channel, the monitoring tool identifies such exceptions. The sections retrieve or publish data and the first step is to determine if the Push feature is enabled. This logic is managed by the Internal exception.
Suggest Edit

Published August 15, 2019 - Updated October 8, 2020

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