Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

pxCommitDateTime column does not exist

SA-53116

Summary



Error on enabling 'Use last updated time as start' checkbox in a BIX extract.


Error Messages



Status
Failed
Percent complete
Total number of records processed
0
Error message
No Instance found in the database
Could not process : pxCommitDateTime column does not exist



Steps to Reproduce

  1. Create a BIX extract rule.
  2. Select the Destination as Database
  3. Enable 'Use last updated time as start' checkbox on the BIX extract.
  4. Run the BIX extract


Root Cause



A defect or configuration issue in the operating environment.

The BIX extract invokes tables that do not contain pxCommitDateTime and pxSaveDateTime columns.


Resolution



Include the pxCommitDateTime and pxSaveDateTime columns in the tables that the BIX extract invokes. Alternatively, run delta extracts that invoke the tables without using pxCommitDateTime and pxSaveDateTime columns. This can be implemented by the below steps.
  1. Navigate to the Filter Criteria of the BIX extract
  2. Disable the Use last updated time as start checkbox
  3. Add a new filter. Set the field to .pxCreateDateTime, operator to Is Greater Than and VALUE to Last Extraction Time.

Published April 13, 2018 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us