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Support Article

pxUpdateOpName not updated when ServiceLevel Agent is executed

SA-66155

Summary



When the goal time is reached for a particular work object the ServiceLevelEvents SLA Agent is triggered and the ExecuteSLA activity is executed.
In Step 22 of the Execute SLA Activity, a mapping is present for pxUpdateDateTime to current DateTime, however, pxupdateopname is not updated.



Error Messages



Not Applicable


Steps to Reproduce

  1. Create a Simple flow.
  2. Set the Goal and Deadline for an SLA rule and add it to the flow.
  3. Create a work object.
  4. Allow the SLA agent to run in the background to update the Goal and Deadline for the work object. Check the Last Updated By value. The value does not change to Agent.


Root Cause



In the Assign-.ExecuteSLA activity, work page is saved using Obj-Save. Hence, the work page's pxSystemUpdateDetailsList is not populated. This page list is later used to prepare the Conflict message which is displayed to the user.

Resolution



Apply HFix-47809.

This modifies the ExecuteSLA activity to update the counter and display a valid conflict message as below.

Suggest Edit

Published March 27, 2019 - Updated October 8, 2020

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