Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

pyCleanupReplayCache is not clearing cache entries

SA-31097

Summary



pyCleanupReplayCache does not clear cache entries.

SAML-based SSO with PING is used as the identity provider.

New records are not inserted into the pr_data_admin table, and the existing records are not modified.


Error Messages



Not Applicable

Steps to Reproduce

  1. Disable the pyCleanupReplayCache agent, and count the number of records for Data-Admin-ReplayCache class in the pr_data_admin table.
  2. Log into the application using SSO URL multiple times.
  3. Count the number of records for Data-Admin-ReplayCache class in the pr_data_admin table, and compare the results with Step 1.
  4. Enable the pyCleanupReplayCache agent, and repeat from Step 1 to Step 3.

Root Cause



There is no description in the History tab for pyCleanupReplayCache so user was not aware what table to check in the database.

Resolution



Check pr_data_saml_replaycache table for the replay entries.

Published May 9, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us