Support Article
pyReply RTE cannot embed image
SA-90731
Summary
Images embedded in the body of a Rich Text Correspondence message are stripped after the message is sent using the SendSimpleEmail reply feature.
When the user sends a reply with the image from the Interaction portal, the image does not display in the mail.
The Reply section allows pictures.
The image is present before the reply is sent.
The Email Recipient views a blank box where the image must display.
Error Messages
Not Applicable
Steps to Reproduce
- Create email interaction by sending email to an email address.
- Press Reply and paste a picture, add text, press Send to send this back to the client.
The email triage is updated correctly and contains picture.
- Check the mailbox for the new correspondence and validate its content. The failed scenario displays as there is no picture. Only the Correspondence logo displays.
- Validate email source. The reference to the image is removed.
Root Cause
A defect in Pegasystems’ code or rules
pyPostTextParser is overridden in the Customer Service layer due to a previous change which related to saving a copy of the 'pypega_social.js' Platform Text File rule in the CS-Specialization ruleset.
Resolution
Apply HFix-57117.
Published October 11, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.