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Support Article

Queue method loses context in agent activity

SA-8204

Summary



A custom agent with custom class was configured to process work objects. The agent uses the Queue method to call an activity, which in turn calls another activity in the background for business needs.
The first activity was called correctly, but the second activity started by Queue method was not found by the system. The context was lost. A runtime exception was generated.

Error Messages



Caused by: com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance System-Queue-TestQueue.TestSample of type Rule-Obj-Activity

Steps to Reproduce



1. Create a custom queue class for an agent.
2. Create a custom agent associated to created class.
3. Create the activity started by the agent, and call the second activity with Queue method.

Root Cause



The agent is configured with a dedicated access group on the security tab. It has access to the expected rulesets to find the activities. Calling the second activity by Queue method breaks the context due to batch requestor’s involvement. 

Resolution



Perform the local-change given below to keep the agent’s context.
Set pzInheritRulesetList parameter to True.

Published February 9, 2016 - Updated October 8, 2020

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