Support Article
Queued Intent tasks are not displayed correctly
SA-35617
Summary
The interaction driver is having issues with displaying intent tasks.
The "queue" option does not appear to work, instead it seems to show up as a "suggestion" within the next best action section on the interaction driver.
Error Messages
Not Applicable
Steps to Reproduce
1. Mark an IntentTask for Queuing and Select an intent when rule.
2. Launch new Interaction.
Observe that queued IntentTask is showed in NextBestArea area.
Root Cause
An issue in the custom application code or rules.
This is an expected behaviour.
Resolution
Here’s the explanation for the reported behavior:
In the current releases of Pega Customer Service (CS) 7.x the Queue and Suggested task options are alike.
IntentTasks marked as Suggested or Queued will be shown under NextBestAction area in InteractionDriver.
Earlier in CPM 6.x, queued tasks are those which will not be launched immediately but are shown in the InteractionDriver screen.
Tags:
Published May 3, 2017 - Updated December 2, 2021
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