Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Radio button does not display as selected post update

SA-63963

Summary



After update to Pega 7.3, on selecting a radio button for the first time in an expandable grid, the row is selected and the row expands. However, the radio button does not display as selected. From second selection onwards, this works fine.




Error Messages



Not Applicable.


Steps to Reproduce

  1. Update from Pega 7.1.8 to Pega 7.3
  2. Create an expandable repeating grid (table)
  3. Add a Click event with the Set Focus and Edit item actions


Root Cause



A defect in Pegasystems’ code or rules.


Resolution

Perform the following local-change:
  1. Include the setRadioButton function in the UserWorkForm HTML fragment:

    <script> 
    function setRadioButton(event){ 
    if(event && event.target
    $(event.target).prop("checked","true"); 

    </script> 

     
  2. One needs to call setRadioButton function via run script action after the actions(set focus,edit item)



 
Suggest Edit

Published September 20, 2018 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us