Support Article
RCA for Hazelcast errors resulting in users not able to use CTI
Summary
A clustered system suffering from hazelcast communication issue and affecting the PegaCALL functionality. Operators not able to login to PegaCALL or doing any other PegaCALL activity.
User requires to know how can hazelcast affect the PegaCALL.
Error Messages
RootExceptionClass : com.hazelcast.core.HazelcastException
RootExceptionMessage : No invocation for response: NormalResponse{callId=1111111, urgent=false, value=com.hazelcast.spi.exception.CallerNotMemberException: Not Member! caller:Address[aa.bbb.c.dd]:xxxx, partitionId: 1, operation: com.hazelcast.map.impl.operation.QueryPartitionOperation, service: hz:impl:mapService, backupCount=0}
TopLevelExceptionClass : com.hazelcast.core.HazelcastException
Steps to Reproduce
Not Applicable
Root Cause
CTI functionality does utilise the hazelcast service.
In general, CTI server pushes messages targeted to the subscribers via one or more PRPC nodes. The PRPC node would receive the message from CTI server and use hazelcast distributed service to publish message to the correct PRPC node, where the subscriber is connected(subscribed).
As such, if the hazelcast service is not functional correctly, the incoming call messages will not be able to deliver to the PRPC node.
Resolution
User must resolve the hazelcast cluster communication issue to restore the PegaCALL functionality.
Published August 24, 2018 - Updated October 8, 2020
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