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Support Article

RDB-List Call failing

SA-35239

Summary



The users notice an error in the Pega Platform logs when they call an RDB-List through an activity.


Error Messages



2017-03-06 19:02:59,065 [ PegaRULES-Batch-7] [ STANDARD] [ ] [Ruleset:Version] ( internal.mgmt.Executable) ERROR - Exception
com.pega.pegarules.pub.PRRuntimeException: caught exception during autocommit check
at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.returnConnection(ConnectionManagerImpl.java:2276)
at com.pega.pegarules.data.internal.access.ThreadConnectionStoreImpl.returnConnection(ThreadConnectionStoreImpl.java:521)
at com.pega.pegarules.data.internal.access.RDBPageResultPackager.close(RDBPageResultPackager.java:897)
at com.pega.pegarules.data.internal.access.DatabaseImpl.executeRDB(DatabaseImpl.java:6648)
at com.pega.pegarules.data.internal.access.DatabaseImpl.executeRDB(DatabaseImpl.java:6581)
at com.pega.pegarules.data.internal.access.DatabaseImpl.listRDB(DatabaseImpl.java:6529)
at com.pegarules.generated.activity.ra_action_activityname_f234b4c8dc8c8e8170e591e41f0e13e8.step1_circum0(ra_action_activityname_f234b4c8dc8c8e8170e591e41f0e13e8.java:274)
at com.pegarules.generated.activity.ra_action_activityname_f234b4c8dc8c8e8170e591e41f0e13e8.perform(ra_action_activityname_f234b4c8dc8c8e8170e591e41f0e13e8.java:69)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3500)
at com.pega.pegarules.session.internal.async.agent.QueueProcessor.runActivity(QueueProcessor.java:721)
at com.pega.pegarules.session.internal.async.agent.QueueProcessor.execute(QueueProcessor.java:602)
at com.pega.pegarules.session.internal.async.BatchRequestorTask.run(BatchRequestorTask.java:945)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.performTargetActionWithLock(PRSessionProviderImpl.java:1259)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:1008)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:901)
at com.pega.pegarules.session.internal.async.BatchRequestorTask.run(BatchRequestorTask.java:670)
at com.pega.jsr166backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:991)
at com.pega.jsr166backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:532)
at java.lang.Thread.run(Thread.java:790)
Caused by:
com.ibm.websphere.ce.cm.ObjectClosedException: DSRA9110E: Connection is closed.


Steps to Reproduce

  1. Advanced agent queues to standard agent
  2. Standard agent runs RDB-List in 1st step and retrieve records
  3. RDB-List is failing and not getting processed.


Root Cause



A defect or configuration issue in the application server : Pega is using a *closed* JDBC connection, which causes the action to fail.

Resolution



Perform the following local-change: Following change to Web Sphere Application Server(WAS) based upon the version is required, which makes WAS check if a connection is usable before assigning it from the connection pool.
In the administrative console, click Resources > JDBC providers.
  1. Select a provider and click Data Sources under Additional properties.
  2. Select a data source and click Web Sphere Application Server data source properties under Additional properties.
  3. Select the PreTest Connections check box.
  4. Type a value for the PreTest Connection Retry Interval, which is measured in seconds. This property determines the frequency with which a new connection request is made after a pretest operation fails.
  5. Type a valid SQL statement for the PreTest SQL String. Use a reliable SQL command, with minimal performance impact; this statement is processed each time a connection is obtained from the free pool.
This worked for WAS 8.

For further details check IBM's support site at http://www-01.ibm.com/support/docview.wss?uid=swg21439688.

Suggest Edit

Published March 26, 2017 - Updated October 8, 2020

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