Support Article
Refreshing harness after attach new note makes fields editable.
SA-33783
Summary
The user reported that when they are adding a note using the advanced link of the case manager portal , all the read only property fields in the portal harness are becoming editable.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Smart Investigate Manager Portal
- Clicked on "Advanced" link in the portal and add a note
- Fields in the "Work Information" and "Transaction Information" Tab are becoming editable
Root Cause
A defect in Pegasystems’ code or rules. Activity named "AutoClose" is sending the parameter "read only" as false to the show-harness (step-2 of the mentioned activity) which is making the fields editable at run time.
Resolution
Local Change provided:
Save as "AutoClose" activity in MYCoSI ruleset and set params before calling the show-Harness.
In Show-Harness, check the "pass current parameter page", as is sending the "read only" param as true which is not making the fields editable at run time.
Published March 24, 2017 - Updated October 8, 2020
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