Support Article

Reindexing for work is failing after some time

SA-29347

Summary



Reindexing for Work is failing after some time its time initiated. 


Error Messages



Reindexing for Work is failing after some time its time initiated.


Steps to Reproduce



Initiate the re indexing, the process is not progressing.


Root Cause



The indexing is taking a long time to run through the 6.5million work objects.  Identified indexing being started fresh in production while the system had an active user load on the system.  
Provided some DASS settings which should help speed up the process. 

Resolution



Perform the following local-change steps:

1. Remove the indexing node from the LB rotation, so no user traffic will be routed to this the node.

2. Disable the FTSIncrementalIndexer agent (edit the data-agent-queue entry) on the indexing node.

3. Backup pr_sys_queue_ftsindexer table.

4. Truncate the pr_sys_queue_ftsindexer table.

5. Increase the value of the following DASS setting:
a. Pega-SearchEngine - indexing/distributed/batch/numworkers to 5

New DASS changes:

b. indexing/distributed/batch/requestbatchsize 100 to 1000
c. indexing/distributed/batch/workqueuesize 10000 to 20000


6. Bring ALL JVM’s down.

7. Backup the pr_sys_statusnodes table.

8. Truncate the pr_sys_statusnodes table.

9. Restart All JVM’s.

10. Validate the FTSIncrementalIndexer agent is NOT running (check in System Management Application (SMA) for the indexing node).

11. Login to the direct URL for the Indexing node which is not in the LB rotation.

12. Validate the Node ID value for the indexing node is the same as seen on the clipboard for that node. Confirm the index path is correct.

13. Build index for the indexing node via search landing page.

14. Enable the ftsincrementalindexer agent queue (update data-agent-queue record) and restart agent queue (from SMA).

The index node needs to stay out of rotation till All indexes are built. Once built one can move it back into rotation and follow the same steps for second index node.

Reference: Pega 7.1.9 installation guide.

 

Published October 19, 2016 - Updated November 15, 2016

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