Support Article
Rejection of Delegated rule
SA-66035
Summary
When a reviewer rejects the delegated rule to delete the private checkout, the system displays a Success message that the checked in changes are deleted and the original rule is unlocked. However, the rule is still locked and user cannot perform any action on it.
Error Messages
Not Applicable
Steps to Reproduce
- Delegate a rule to a particular access group.
- Log in with the user ID for whom the rule is delegated.
- Click 'Configure' to open the list of delegated rules.
- Click Edit over the delegated rule.
- Check-out the rule and check-in after the changes are made. The rule is submitted to the reviewer for approval.
- Log in with the Reviewer user ID.
- Click the CheckInCandidates available work basket.
- Click the rule ID that is submitted for approval in Step 5.
- Click Actions and select 'Reject changes and delete private copy'.
- Enter a note and click the Submit button. Success message displays that candidate rule is deleted and the original rule is unlocked.
- Log in with the same user ID (Step 2). The rule is still locked.
Root Cause
A defect or configuration issue in the operating environment: Locking issue.
The lock is not released when the reviewer rejects the rule changes in the delegated rule. The metadata set on the private rule is not reset when the Work-RuleCheckin changes are rejected.
Resolution
- Override the Work-RuleCheckin.Reject flow action.
- Change the post processing activity to a new activity (DeleteRulesWrapper).
- Create the 'DeleteRuleWrapper' activity.
- Invoke the DeleteRules (this is the original post processing activity in Reject flow action).
- Invoke the ProcessRMAction on the PrivateRule (processing is required before invoking this activity). See the below screenshot:
Published October 8, 2020
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