Support Article
Release Lock activity logs off the other user
SA-5342
Summary
Developers are using the release lock activity to release the lock held by the same operator, different requestor. In this, the other user gets logged off which is not acceptable. On a multi-node environment, this feature does not work at all.
Error Messages
Not Applicable
Steps to Reproduce
1. Log into the Case Manager portal and open any work object.
2. Open another browser session and log into the same user and open the portal.
3 Try opening the same work object, open by the first requester.
4. A dialog appears stating "end other session to release lock".
5. Click on the button and the second requester acquires the lock.
6. Try performing any operation on the first requester and you are redirected to login screen.
7. Try the same thing on a multi-node environment and Release Lock does not work.
Root Cause
Logging off while taking the lock from another requestor is an expected behaviour. In a multi-node environment, system pulse takes time to update the cache across the nodes and hence the option does not take effect immediately.
Resolution
HFix-20494 was installed to resolve this issue.
Published January 31, 2016 - Updated October 8, 2020
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