Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Release Lock is not working in multi-node environment

SA-19956

Summary



When attempting to release a lock in multi-node environment it does not work in Pega 7.1.8. 

Error Messages


Not Applicable.


Steps to Reproduce

  1. With Work Object 1 opened by User A, on Requestor 1 and attempting to unlock on Requestor 2, Node 2.
  2. Click the release lock button.
  3. Observe that it is not working and returns to the same screen.


Root Cause



A defect or configuration issue in the operating environment.

Resolution



Here’s the explanation for the reported behavior: 

In the Pega 7.1.8 version the release lock process uses the system pulse to propagate the lock expiration to the other nodes.
​This is by default configured to be a minute.

Try to unlock following this PDN link:

https://pdn.pega.com/sites/pdn.pega.com/files/help_v72/procomhelpmain.htm#concepts/concepts2/conceptslocking.htm
Suggest Edit

Published February 23, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us