Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Repeat grid with RTE does not load

SA-31292

Summary



User has a repeating grid with around 150 records.

The page hangs when the grid loads. However, the data does appear after a significant amount of time. When user tries to submit this data, the screen freezes again.


Error Messages



Not applicable


Steps to Reproduce



1. Create a section and include a repeating grid. This grid would contains Rich Text Editor (RTE) control. 
2. Create around 100-150 records for the grid. 
3. Use RTE control in read only mode. 
4. Create a flow for the same and run the flow. 

Root Cause



For all RTE instances in grid, separate RTE initialization happens, that could be time consuming execution. Also, user is using RTE inside a grid with RTE control as read only.

Resolution



Since RTE is used as read only, user is suggested to use other control like FormattedText.
Suggest Edit

Published December 26, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us