Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Repeating grid does not display in an email

SA-93100

Summary



On incorporatin a section (which has a table in it) in a Correspondence rule, the value in this section does not display in the correspondence. Additionally, the grid does not display in a table format.




Error Messages



Not Applicable


Steps to Reproduce

  1. Create a section containing a repeating grid (table).
  2. Refer the section in the Correspondence rule.


Root Cause



An issue in the custom application code or rules.
User passed the table values after sending the mail. As a result, data is not present in the grid. The styles and the border lines of the grid are not present because the Pega styles are not carried out to the email which is an external system.



Resolution



Perform the following local-change:

For data to display in the email, change the steps in the activity which generates the email.

For the table Styles (that is, when the border does not display), perform the below steps,
  1. Create a non-auto generated section.
  2. Include this section in the Correspondence rule at the beginning of the correspondence.
  3. Include the below code in the section,

    <style>
    table {
      border-collapse: collapse !important;
    }

    table, td, th {
      border: 1px solid black !important;
    }
     </style>
Suggest Edit

Published April 1, 2020 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us