Support Article
Report browser does not launch report in new portal
SA-75604
Summary
When using the report browser in a newly created portal, the page loads and the report lists display on clicking the different Categories. However, the report Viewer does not launch on clicking the report links.
Error Messages
Not Applicable
Steps to Reproduce
- Create a new portal.
- Set the following,
Role = User
Type = Composite
Harness applies to = Data-Portal
Harness name = pyCMReportBrowser7
- Associate the new portal with an access group.
- Log in with the access group and launch the new portal. The report Browser displays.
- Click any item in the Public categories. This refreshes the report list with reports from that category.
- Click any report in the list. The report does not display.
Root Cause
An issue in the custom application code or rules.
When using the pyCMReportBrowser7, the browser is disconnected from the Case Manager portal and does not open a report in the New Document mode.
Resolution
Perform the following local-change:
OnClick of the Report, change the report definition mode to Popup instead of New Document.
Published April 5, 2019 - Updated December 2, 2021
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