Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Report browser does not launch report in new portal

SA-75604

Summary



When using the report browser in a newly created portal, the page loads and the report lists display on clicking the different Categories. However, the report Viewer does not launch on clicking the report links.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a new portal.
  2. Set the following,

    Role = User
    Type = Composite
    Harness applies to = Data-Portal
    Harness name = pyCMReportBrowser7

     
  3. Associate the new portal with an access group.
  4. Log in with the access group and launch the new portal. The report Browser displays.
  5. Click any item in the Public categories. This refreshes the report list with reports from that category.
  6. Click any report in the list. The report does not display.


Root Cause



An issue in the custom application code or rules.
When using the pyCMReportBrowser7, the browser is disconnected from the Case Manager portal and does not open a report in the New Document mode.



Resolution



Perform the following local-change:

OnClick of the Report, change the report definition mode to Popup instead of New Document. 

Published April 5, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us