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Support Article

Report count not updated for Report Categories

KCP-480

Summary

 

On adding a new report to any Report Category, the count is not updated. When the user logs off and logs in, the updated count displays. 


ERROR MESSAGES 

Not Applicable 


Steps to Reproduce

  1. Open the Case Manager portal.
  2. Click Report Browser.
  3. Click Add category.
  4. Create a new category (Public/Private).
  5. Open any existing report.
  6. Save as the report to the new category.


ROOT CAUSE 

A defect in Pegasystems’ code or rules.


Resolution



Perform the following local-change:

In pyCMReportBrowserHeader, add a custom control pzRBIncludes7. The pzRBIncludes7 control performs a refresh after the report is added to the category.
Suggest Edit

Published December 2, 2021

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