Support Article
Report Definition - Advance Filter not working as expected
SA-3009
Summary
Report definition Advance Filter not working as expected (Used Custom Filter section).
When we run a report we get values fetched based on the filter conditions provided , say 10 pages are fetched , if we go to the 5th page and click on the Advance Filter option & change the filter condition & submit the report either the same 10 rows are pertained or no results are fetched , even though there are values for the filter condition provided in the DB
Error Messages
NA
Steps to Reproduce
1. Create a Report Definition rule
2. Create a custom filter (Eg : Date field)
3. Run the report such that it fetches more than 10 pages (Each page having 50 records)
4. Run Advance filter on the first page ,check the results fetched
5. Again launch the report afresh, with the same filter condition as step 2
6. now go to the 5th or 6th page and run the Advance Filter , check the results (Either No records are fetched or the previously fetched records persist without getting changed)
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules.
PRPC tries to display the records for the current page index which is incorrect. If there are no records here, then 0 records are displayed for the report:
Example: A report is run and shows 10 pages with a page size of 20, which means in total there are 200 records. Now user navigates to the 10th page and selects the advanced filter option and modifies the filter criteria. With the new criteria, let’s assume in total 100 records would be returned , thus the max page size would be 5. However, since the user current page index is 10, PRPC shows zero records for the report in this case
Resolution
This issue is resolved by hotfix item Hfix-10270
Published January 31, 2016 - Updated October 8, 2020
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