Support Article
Report Definition: Export to excel is taking a long time
SA-31942
Summary
User is using Pega 7.1.8 with Pega Claims Workstation+ for Healthcare framework version 7.11.
User is trying to export the contents of the Report Definition to Excel.
When the export records are more than 10,000, the export to excel takes a very long time. User is experiencing poor performance and some times, it times out with an exception being displayed.
Error Messages
Not applicable
Steps to Reproduce
1. Create the report definition.
2. Run the report definition.
3. Click on Export excel.
4. Make sure that export records should be more than 10000.
Root Cause
Values of the below parameters were provided smaller numbers.
- Maximum elapsed time in seconds
- Maximum number of rows for export
- Maximum elapsed time in seconds for export
Resolution
Perform the following local-change steps:
Increase the value for the below properties in Data Access Tab:
1. Open the Report Definition > Data Access Tab.
2. Increase the values for the following parameters:
- Maximum elapsed time in seconds
- Maximum number of rows for export
- Maximum elapsed time in seconds for export
And also check "Ignore formatting when exporting to excel".
Note:Perform a trial to check what value gives the least performance issue.
Note: One has to keep playing with the numbers until and unless they get the least amount time for downloading.
Published January 5, 2017 - Updated October 8, 2020
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