Support Article
Report Definition filter condition is hanging the webpage
SA-21549
Summary
User has reported issue with a grid configured with report definition which fetches the records of around 2100 case ID's, in the QA and development environment when the user filter option on the grid column. It takes a lot of time in loading after selection filter option and also some times throws error "The webpage has a long running script which is not responding" .
This issue occurs only in IE 11 and works as expected in Chrome:47.0.
Observations in IE :
- While system is loading filter results , user is unable to do any other action in that time.
- When the error "The webpage has a long running script which is not responding" is thrown, when we click 'Stop script' button then the sometime the screen refreshes and goes back to initial page and some times implements the filter condition entered.
- When tried to reduce the number of case ID's to half in the report, the upon setting filter condition, it takes comparatively less time to load results and also does not throw the error.
Error Messages
IE gives "The webpage has a long running script which is not responding" message.
Steps to Reproduce
1) Create a a Report Definition with 3000+ unique records.
2) Create a Repeat Grid and configure it with Report Definition created in Step1.
3) Run the Repeat Grid and click on filter option of column having unique values.
Root Cause
A third-party product issue:
The behavior is specific to IE only.
It is the browser behavior that it is not able to loop through the list of rows in the grid, to fetch the results in the given time and hence it is giving that message.
It is a performance issue of the IE browser and there is no scope to optimize the grid component code to perform better in the IE.
Resolution
Perform the following local-change:
1) Open the grid design time configuration and click on the dot of the column as shown in below screen print.

2) Open properties of the column as shown below

3) Change the filtering configuration option from "Auto" to "Range/Search" as shown below.

4) Select the value.

Published April 4, 2016 - Updated October 8, 2020
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